





























































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="5798143" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=bd25440b1c5ad020d52d8f6ef737fad1" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=bd25440b1c5ad020d52d8f6ef737fad1" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=bd25440b1c5ad020d52d8f6ef737fad1" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=bd25440b1c5ad020d52d8f6ef737fad1" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/karnak-6-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Cleveland Scene RSS: Whole Site" href="http://www.clevescene.com/cleveland/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Cleveland Scene RSS: Blogs Section" href="http://www.clevescene.com/cleveland/Rss.xml?oid=4537827" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Cleveland Scene RSS: Scene and Heard: Scene&#39;s News Blog" href="http://www.clevescene.com/cleveland/Rss.xml?oid=1518254" />
      
        <link rel="alternate" type="application/rss+xml" title="Cleveland Scene RSS: Scene and Heard: Scene&#39;s News Blog: " href="http://www.clevescene.com/cleveland/Rss.xml?category=1518254&amp;topic=oid%3A1550692" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Cleveland Scene RSS: Comments on Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down" href="http://www.clevescene.com/cleveland/Rss.xml?id=comments&amp;oid=5798143" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=2b91b4870a"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=2b91b4870a"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/www.clevescene.com\/cleveland\/Profile", "http:\/\/posting.clevescene.com\/cleveland\/MyProfile");
  </script>
  
  
  
  
  
  

    
  

  
  <!-- Google Fonts -->
<link href='http://fonts.googleapis.com/css?family=Righteous' rel='stylesheet' type='text/css'>
<link href="http://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700" rel="stylesheet" type="text/css">
<! -- End Google Fonts -->

<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>
              googletag.cmd.push(function() { 
            Foundation = Foundation || {};
            Foundation.Ad = Foundation.Ad || {};
            Foundation.Ad.slots = Foundation.Ad.slots || {};
                Foundation.Ad.slots['div-gpt-ad-cle_reskin'] = googletag
        .defineOutOfPageSlot('/43707298/CLE_Reskin', 'div-gpt-ad-cle_reskin')
        .setTargeting('oop', ['reskin'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-cle_desktopinterstitial'] = googletag
        .defineOutOfPageSlot('/43707298/CLE_DesktopInterstitial', 'div-gpt-ad-cle_desktopinterstitial')
        .setTargeting('oop', ['desktop-interstitial'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-cle_desktopnative_2'] = googletag
          .defineOutOfPageSlot('/43707298/CLE_DesktopNative', 'div-gpt-ad-cle_desktopnative-2')
          .setTargeting('oop', ['native-Inline'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
        Foundation.Ad.slots['div-gpt-ad-cle_desktopnative_3'] = googletag
          .defineOutOfPageSlot('/43707298/CLE_DesktopNative', 'div-gpt-ad-cle_desktopnative-3')
          .setTargeting('oop', ['native-EndOfArticle'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-cle_300x250_1'] = googletag
          .defineSlot('/43707298/CLE_300x250', [300,250], 'div-gpt-ad-cle_300x250-1')
          .setTargeting('placement',['ATF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
        Foundation.Ad.slots['div-gpt-ad-cle_300x250_2'] = googletag
          .defineSlot('/43707298/CLE_300x250', [300,250], 'div-gpt-ad-cle_300x250-2')
          .setTargeting('placement',['BTF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
        Foundation.Ad.slots['div-gpt-ad-cle_300x250_3'] = googletag
          .defineSlot('/43707298/CLE_300x250', [[300,250], [300,600]], 'div-gpt-ad-cle_300x250-3')
          .setTargeting('placement',['BTF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-cle_728x90_1'] = googletag
          .defineSlot('/43707298/CLE_728x90', [728, 90], 'div-gpt-ad-cle_728x90-1')
          .setTargeting('placement',['ATF'])
          .setTargeting('media', ['screen']).addService(googletag.pubads());
      Foundation.Ad.slots['div-gpt-ad-cle_728x90_2'] = googletag
        .defineSlot('/43707298/CLE_728x90', [728, 90], 'div-gpt-ad-cle_728x90-2')
        .setTargeting('placement',['BTF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-cle_970x90'] = googletag
        .defineSlot('/43707298/CLE_970x90', [[970,90], [970,250]], 'div-gpt-ad-cle_970x90')
        .setTargeting('placement',['ATF'])
        .setTargeting('media', ['screen']).addService(googletag.pubads());
                googletag.pubads().setTargeting('template', ["Post"]);
                googletag.pubads().setTargeting('media', ["screen"]);
                googletag.pubads().setTargeting('section', ["blogs"]);
                googletag.pubads().setTargeting('category', ["scene-and-heard"]);
                googletag.pubads().setTargeting('oid', ["5798143"]);
                googletag.pubads().setTargeting('topic', ["bites"]);
                googletag.pubads().setTargeting('tags', ["fresh and meaty burgers"]);
                googletag.pubads().setTargeting('vertical', ["food"]);
                googletag.pubads().setTargeting('category_type', ["Blog"]);
                googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
              googletag.enableServices();
                Foundation.Ad.refresh = function (id) {
                  if (id && Foundation.Ad.slots[id]) {
                    googletag.pubads().refresh([Foundation.Ad.slots[id]]);
                  }
                  else {
                    googletag.pubads().refresh();
                  }
                };
                Foundation.Ad.refreshlockout = false;
                if (window.jQuery) {
                  jQuery(document).on("foundation:ad:refresh", function(event) {
                    if (Foundation.Ad.refreshlockout == false) {
                      Foundation.Ad.refreshlockout = true;
                      window.setTimeout(function () {
                        Foundation.Ad.refreshlockout = false;
                      }, 5000);
                      Foundation.Ad.refresh();
                    }
                  });
                }
              }); 
          </script>

<link href="https://plus.google.com/+clevescene" rel="publisher" />

<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-5882309-1', 'clevescene.com');
    ga('send', 'pageview', { 'dimension1': 'blogs', 'dimension3': 'food' });
    </script>
  
  <!-- End Google Analytics -->
  
<!-- xxxdebug dining -->
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down | Scene and Heard: Scene&#39;s News Blog" />
  <meta name="description" content="God bless Fresh and Meaty Burgers (13187 Cedar Rd., 216371-4400). Most of us love a good quality hamburger, but the only options tend to be..." />
  <meta name="keywords" content="fresh and meaty burgers, Bites" />
  <title>Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down | Scene and Heard: Scene's News Blog</title>

  
  
  
    <meta name="author" content="Douglas Trattner">
  

  
  
  <meta name="news_keywords" content="fresh and meaty burgers, bites" />

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/clevescene/imager/u/slideshow/5798910/fresh_and_meaty_burger.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/clevescene/imager/u/slideshow/5798910/fresh_and_meaty_burger.jpg" />
  

  
    
      <link rel="canonical" href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" />
    
  

  
    <meta property="fb:app_id" content="242962682388947" />
  

  
  <meta property="og:site_name" content="Cleveland Scene" />
  <meta property="og:title" content="Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down" />
 
  
    <meta property="og:image" content="https://media1.fdncms.com/clevescene/imager/u/slideshow/5798910/fresh_and_meaty_burger.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="738" />
    
  

  
  
    <meta property="og:description" content="God bless Fresh and Meaty Burgers (13187 Cedar Rd., 216371-4400). Most of us love a good quality hamburger, but the only options tend to be..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">5798143</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20170316160930</Attribute>
        <Attribute name="creationdate">20170316155643</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20170316160900</Attribute>
            <Attribute name="releasedate">20170316</Attribute>
            <Attribute name="releaseepoch">1489694940</Attribute>
            <Attribute name="title">Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down</Attribute>
            <Attribute name="author">1520396</Attribute>
            <Attribute name="authorname">Douglas Trattner</Attribute>
            <Attribute name="authorsortname">Trattner, Douglas</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/www.clevescene.com\/scene-and-heard\/archives\/2017\/03\/16\/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down"
          },
          "headline": "Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down",
          
            "description": "God bless Fresh and Meaty Burgers (13187 Cedar Rd., 216371-4400). Most of us love a good quality hamburger, but the only options tend to be unwholesome fast food joints or places that compel us to sit down and order from a server.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/clevescene\/imager\/u\/original\/5798910\/fresh_and_meaty_burger.jpg",
              "width": 3024,
              "height": 3717,
              "@type": "ImageObject"
            },
          
          "datePublished": "2017-03-16T16:09:00",
          "dateModified": "2017-03-16T16:09:30",
          
            "author": {
              "name": "Douglas Trattner",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Cleveland Scene",
            
              
              
              
              "logo": {
                "url": "http:\/\/www.clevescene.com\/imager\/b\/google-amp-logo\/808579\/0282\/adminIcon_clevescene.jpg",
                "width": 366,
                "height": 366,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/clevescene/imager/u/slideshow/5798910/fresh_and_meaty_burger.jpg">

    
    

    

    <meta name="twitter:site" content="@Cleveland_Scene">
    <meta name="twitter:title" content="Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down">
    <meta name="twitter:description" content="God bless Fresh and Meaty Burgers (13187 Cedar Rd., 216371-4400). Most of us love a good quality hamburger, but the only options tend to be...">
  
</head>





  <body id="Post" class="BlogPost blogs Karnak6Zone scene-and-heard">



<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5LHFPG"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5LHFPG');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  






      <style>
      /*-- desktop styles --*/
       #AdBackground {top:50px!important;}
      .nominate-bar {
        background:#D91F34;
        z-index: 1;
        overflow:hidden;
        padding: 0;
        text-transform: uppercase;
        text-align: center;
        color: #fff;
        font-size: 17px;
        width: 980px;
        margin: 0 auto;
      }
      .nominate-bar div {
        border: 1px solid #fff;
        margin: 5px;
        max-width: 1000px;
      }
      .nominate-bar a {
        color:#fff;
      }
      </style>
  

  <div class="nominate-bar">
  	<div>
      <p><a href="http://posting.clevescene.com/cleveland/Survey?survey=5022717" target="_new">Vote Here and Now for Best of Cleveland 2017<sup>&#174;</sup>!</a></p>
      </div>
  </div>
<div id="AdInterstitial" class="Leader BlogPost ">
  <!-- /43707298/CLE_DesktopInterstitial -->
          <div id="div-gpt-ad-cle_desktopinterstitial" style="" data-slot="/43707298/CLE_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_desktopinterstitial');
                });
            </script>
          </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="http://m.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  















<div id="LogoHeader" class="GlobalHeader BlogPost ">
  
    
    <div id="logoLeft">      
      <a href="http://www.clevescene.com/" title="Cleveland Scene">Cleveland Scene</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/CLE_728x90 -->
          <div id="div-gpt-ad-cle_728x90-1" style="" data-slot="/43707298/CLE_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_728x90-1');
                });
            </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->






















  <div id="NavigationHorizontal" class="GlobalHeader BlogPost ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_home">
          <a href="http://www.clevescene.com/"  class="subnav_link" id="SNAVL_home">Home</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_news">
          <a href="http://www.clevescene.com/cleveland/news/Section?oid=1392923"  class="subnav_link" id="SNAVL_news">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_music">
          <a href="http://www.clevescene.com/cleveland/music/Section?oid=1392924"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_film">
          <a href="http://www.clevescene.com/cleveland/film/Section?oid=1392922"  >Movies</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_dining">
          <a href="http://www.clevescene.com/cleveland/dining/Section?oid=1392921"  >Eat</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_arts">
          <a href="http://www.clevescene.com/cleveland/arts/Section?oid=1392919"  >Arts</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Slideshows">
          <a href="http://photos.clevescene.com/" target="_blank" >Slideshows</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_events">
          <a href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Today"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_specialsections">
          <a href="http://www.clevescene.com/cleveland/special-sections/Section?oid=1518239"  class="subnav_link" id="SNAVL_specialsections">Special Issues</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_bestof">
          <a href="http://www.clevescene.com/cleveland/Survey?survey=5022717"  >Best Of</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Giveaways">
          <a href="http://www.clevescene.com/cleveland/FreeStuff?category=4531976"  >Giveaways</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_SceneMagazineEvents">
          <a href="http://www.clevescene.com/cleveland/FreeStuff?category=4531979"  >Scene Events</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_news" style="display:none;">
          

          

          <li class="">
            <a href="http://www.clevescene.com/cleveland/IssueArchives?issue=this%20week" target="_blank" title="">e-Edition</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

    
  


<!-- End #NavigationHorizontal --><div id="Pencil" class="GlobalHeader BlogPost Pencil Ad">  
  <!-- /43707298/CLE_970x90 -->
          <div id="div-gpt-ad-cle_970x90" style="" data-slot="/43707298/CLE_970x90" data-output="asynchronous" data-width="970" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_970x90');
                });
            </script>
          </div>
</div>
    <!-- end gridHeader -->
  </div>

  <div id="gridMain">

    <!-- ZoneA -->
    <div id="gridMainColumn">
      



  <div id="TopicHeader" class="MainColumn BlogPost  topic_bites">      
       <a href="http://www.clevescene.com/scene-and-heard/archives/bites/">
         <h2 id="ArchiveHead" class="archiveHead">
           Bites
         </h2>
       </a>   
      
  </div>  




  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: http://www.clevescene.com
    var.publicDesktopServer = http://www.clevescene.com
    var.shareUrl = http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down
    s/http\:\/\/www\.clevescene\.com/http\:\/\/www\.clevescene\.com/
    var.shareUrl = http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down
  -->




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MainColumn BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        



<div id="FacebookShareButtonCount" class="MicroComponent ToolBarHorizontal ">
  <div class="fb-share-button" data-type="button_count" data-href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down"></div>
</div></div> <div class="l0" style="width:14%; height: 20px; float:left;"><a href="http://twitter.com/share?url=http%3A//www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down&text=Fresh%20and%20Meaty%20Burgers%20Tastefully%20Fill%20Void%20Between%20Fast%20Food%20and%20Sit-Down" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:14%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="http://posting.clevescene.com/cleveland/Tools/EmailFriend?oid=5798143" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="http://posting.clevescene.com/cleveland/Profile/MyFavorites?add=5798143">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="5798143" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-4ee1499336aa532c" addthis:url="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" addthis:title="Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4ee1499336aa532c", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  










  
  
  
  









  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  

  <div id="BlogsBlogPost" class="MainColumn BlogPost  topicView topic_bites">
    
    
    
    
    
    
      
      
        <h2 class="blogDate">Thursday, March 16, 2017</h2>
      
    
      
      <div class="blogPost scene-and-heard topic-bites">
    
    
      <div class="postCategories">
        <span class="postCategory Categoryscene-and-heard">
          <a href="http://www.clevescene.com/scene-and-heard/archives/bites/" class="topic-bites">Bites</a>
        </span>
      </div>
    
    <h3 class="postTitle" id="a5798143">
      
      
      
      
      
      
        Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        Posted
        
          
          By <a href="http://www.clevescene.com/cleveland/ArticleArchives?author=1520396" rel="author">Douglas Trattner</a>
        
        
          
            on <span class="postTime">Thu, Mar 16, 2017</span> at <span class="postTime"> 4:09 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      
      
       
      
        
        

        
        
          
        
        

        
        <!-- myParagraphType: <br>, myParagraphCount: 7 -->
        
         
      
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/clevescene/imager/u/original/5798910/fresh_and_meaty_burger.jpg" class="zoomable" rel="contentImg_gal-5798143" title="">                  <img src="https://media1.fdncms.com/clevescene/imager/u/blog/5798910/fresh_and_meaty_burger.jpg?cb=1489694751" width="250" height="307" alt="fresh_and_meaty_burger.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>God bless <a href="http://www.freshandmeatyburgers.com/" target="_blank">Fresh and Meaty Burgers</a> (13187 Cedar Rd., 216371-4400). Most of us love a good quality hamburger, but the only options tend to be unwholesome fast food joints or places that compel us to sit down and order from a server. The lack of local, independent places that land somewhere in the middle is staggering.<br>
<br>
Fresh and Meaty opened in a corner spot in Cleveland Heights that has seen more than its share of come-and-go restaurants. But here since fall, this place seems to be holding its own thanks to a simple and appealing approach to food. They sell burgers, mainly, and they start with fresh patties that are cooked to order.<br>
<br>
<div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/clevescene/imager/u/original/5799165/fresh_and_meaty_menu.jpg" class="zoomable" rel="contentImg_gal-5798143" title="">                  <img src="https://media2.fdncms.com/clevescene/imager/u/blog/5799165/fresh_and_meaty_menu.jpg?cb=1489694856" width="250" height="222" alt="fresh_and_meaty_menu.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>“We are a traditional American hamburger stand," says owner Gerald Hood. "What that means is that we don't put nothing on burgers that don't belong on burgers."<br>
<br>

F&amp;M offers three patty sizes, giving diners total control over burger and portion size. There’s a little bitty 3-ounce “baby,” a 6-ounce “meaty,” and half-pound “king.” Diners can double-up any of those sizes except the baby, making a hefty stack, and can even swap the beef for fresh ground turkey.

<br>

<div id="AdNativeInline" class="MainColumn AdNativeInline "> <!-- /43707298/CLE_DesktopNative --> <div id="div-gpt-ad-cle_desktopnative-2" style="" data-slot="/43707298/CLE_DesktopNative" data-output="asynchronous" data-width="" data-height=""> <script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-cle_desktopnative-2'); }); </script> </div> </div>

<br>
<div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/clevescene/imager/u/original/5799137/fresh_and_meaty_menu_two.jpg" class="zoomable" rel="contentImg_gal-5798143" title="">                  <img src="https://media1.fdncms.com/clevescene/imager/u/blog/5799137/fresh_and_meaty_menu_two.jpg?cb=1489694862" width="250" height="333" alt="fresh_and_meaty_menu_two.jpg" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>The rustic, hand-formed patties are cooked on a flattop, slid onto a toasted bun, and automatically topped with lettuce, tomato, onion, mustard, mayo, pickles and relish unless otherwise requested. Thick-cut, skin-on spuds are fried to order and dusted with a salty spice mix. <br>
<br>

The prices are more than reasonable for the freshness, quality and portion of the food.<br>
<br>
Next time you're in the area and hankering for a great burger, give them a try.<br>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="http://www.clevescene.com/cleveland/ArticleArchives?tag=fresh%20and%20meaty%20burgers" rel="tag">fresh and meaty burgers</a>, <a href="http://www.clevescene.com/cleveland/ArticleArchives?contentFeature=3360849" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>







<div id="JumptoComments" class="MainColumn BlogPost ">
  <a href="#readerComments">Jump to comments (0)</a>
</div><!-- End JumptoComments -->




  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  




    
    
    
    


















  





  
  

















  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MainColumn BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        



<div id="FacebookShareButtonCount" class="MicroComponent ToolBarHorizontal ">
  <div class="fb-share-button" data-type="button_count" data-href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down"></div>
</div></div> <div class="l0" style="width:14%; height: 20px; float:left;"><a href="http://twitter.com/share?url=http%3A//www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down&text=Fresh%20and%20Meaty%20Burgers%20Tastefully%20Fill%20Void%20Between%20Fast%20Food%20and%20Sit-Down" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:14%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="http://posting.clevescene.com/cleveland/Tools/EmailFriend?oid=5798143" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="http://posting.clevescene.com/cleveland/Profile/MyFavorites?add=5798143">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="5798143" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-4ee1499336aa532c" addthis:url="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/fresh-and-meaty-burgers-tastefully-fill-void-between-fast-food-and-sit-down" addthis:title="Fresh and Meaty Burgers Tastefully Fill Void Between Fast Food and Sit-Down" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4ee1499336aa532c", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  


























  
  
  

<div id="AdNativeEndofArticle" class="MainColumn BlogPost ">
  <!-- /43707298/CLE_DesktopNative -->
          <div id="div-gpt-ad-cle_desktopnative-3" style="" data-slot="/43707298/CLE_DesktopNative" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_desktopnative-3');
                });
            </script>
          </div>
</div>


  
  

  <div id="BlogsPreviousNext" class="MainColumn BlogPost ">
    <div class="prevNext">
      <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/cuyahoga-county-jail-officer-arrested-for-allegedly-smuggling-heroin-into-jail-for-inmate-accused-of-rape" class="prev" rel="prev">&laquo;&nbsp;Cuyahoga County Jail Officer Arrest&hellip;</a>
    </div>
  </div>





  
  

  

  

  <div id="BlogHeader" class="MainColumn BlogPost  topic_bites scene-and-heard">
    <a href="http://www.clevescene.com/blogs/scene-and-heard/">
    <h1 class="scene-and-heard">
      
        Scene and Heard: Scene's News Blog
      
    </h1>
    </a>

    

    <p>
      
        <a href="http://www.clevescene.com/cleveland/scene-and-heard/blogs/Archives">Archives</a> |
        <a href="/cleveland/Rss.xml?category=1518254">RSS</a>
      
      
    </p>
  </div>







  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="MainColumn BlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="5798143" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/cleveland/Rss.xml?id=comments&amp;oid=5798143" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="5798143" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  


      <!-- end gridMainColumn -->
    </div>

    <div id="gridRightColumn">
    
      <!-- ZoneB -->
      <div id="gridMainSidebar">
        









<div id="TabbedPopularity" class="MainSidebar BlogPost ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    
        <ol class="moduleList">
      
      
      <li>
        <h4 class="headline"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/our-favorite-dumb-bad-yelp-reviews-of-cleveland-restaurants?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Our Favorite Dumb Bad Yelp Reviews of Cleveland Restaurants <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/luke-stewart-was-unarmed-when-euclid-police-officer-shot-him-during-altercation?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Luke Stewart Was Unarmed When Euclid Police Officer Shot Him During Altercation <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/vote-for-the-finalists-in-best-of-cleveland-2017-right-now?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Vote for the Finalists in Best of Cleveland 2017 Right Now <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/16/45-years-ago-this-week-in-scene?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">45 Years Ago This Week in Scene <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/03/loganberry-books-shelves-mens-books-backwards-as-a-metaphor-of-silencing-the-male-voice?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Loganberry Books Shelves Men's Books Backwards as a 'Metaphor of Silencing the Male Voice' <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    

    
        <ol class="moduleList">
      

      
      <li>
        <h4 class="headline">
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/03/loganberry-books-shelves-mens-books-backwards-as-a-metaphor-of-silencing-the-male-voice#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Loganberry Books Shelves Men's Books Backwards as a 'Metaphor of Silencing the Male Voice'</a>
          
           <span class="commentCount"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/03/loganberry-books-shelves-mens-books-backwards-as-a-metaphor-of-silencing-the-male-voice#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">25</a></span>
          
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/03/loganberry-books-shelves-mens-books-backwards-as-a-metaphor-of-silencing-the-male-voice#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><span class="more">Read More</span></a>
        </h4>
      </li>
      
    

      
      <li>
        <h4 class="headline">
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/06/nbc-nightly-news-covers-growing-heroin-epidemic-in-ohio-with-a-family-destroyed-by-addiction-video#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">NBC Nightly News Covers Growing Heroin Epidemic in Ohio with a Family Destroyed By Addiction: VIDEO</a>
          
           <span class="commentCount"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/06/nbc-nightly-news-covers-growing-heroin-epidemic-in-ohio-with-a-family-destroyed-by-addiction-video#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">18</a></span>
          
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/06/nbc-nightly-news-covers-growing-heroin-epidemic-in-ohio-with-a-family-destroyed-by-addiction-video#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><span class="more">Read More</span></a>
        </h4>
      </li>
      
    

      
      <li>
        <h4 class="headline">
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/10/atandt-has-historically-excluded-clevelands-poorest-neighborhoods-from-its-internet-access-improvements#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">AT&T Has Historically Excluded Cleveland's Poorest Neighborhoods From Its Internet Access Improvements</a>
          
           <span class="commentCount"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/10/atandt-has-historically-excluded-clevelands-poorest-neighborhoods-from-its-internet-access-improvements#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">17</a></span>
          
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/03/10/atandt-has-historically-excluded-clevelands-poorest-neighborhoods-from-its-internet-access-improvements#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><span class="more">Read More</span></a>
        </h4>
      </li>
      
    

      
      <li>
        <h4 class="headline">
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/02/28/armond-budish-is-a-willing-accomplice-to-dan-gilberts-latest-arena-subsidy-scam#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Armond Budish Is a Willing Accomplice to Dan Gilbert's Latest Arena Subsidy Scam</a>
          
           <span class="commentCount"><a href="http://www.clevescene.com/scene-and-heard/archives/2017/02/28/armond-budish-is-a-willing-accomplice-to-dan-gilberts-latest-arena-subsidy-scam#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">17</a></span>
          
          <a href="http://www.clevescene.com/scene-and-heard/archives/2017/02/28/armond-budish-is-a-willing-accomplice-to-dan-gilberts-latest-arena-subsidy-scam#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><span class="more">Read More</span></a>
        </h4>
      </li>
      
    

      
      <li>
        <h4 class="headline">
          <a href="http://www.clevescene.com/scene-and-heard/archives/2016/12/29/davis-besse-nuclear-power-station-could-soon-be-closed-or-sold-by-firstenergy#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">FirstEnergy Will Sell or Close Both Ohio Nuclear Power Plants</a>
          
           <span class="commentCount"><a href="http://www.clevescene.com/scene-and-heard/archives/2016/12/29/davis-besse-nuclear-power-station-could-soon-be-closed-or-sold-by-firstenergy#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">17</a></span>
          
          <a href="http://www.clevescene.com/scene-and-heard/archives/2016/12/29/davis-besse-nuclear-power-station-could-soon-be-closed-or-sold-by-firstenergy#readerComments?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity"><span class="more">Read More</span></a>
        </h4>
      </li>
      
    
        </ol>
      

  </div>

  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="http://www.clevescene.com/cleveland/IssueArchives?issue=5739438&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/5739438/2c81/03-15-COVER.jpg" alt="Issue Cover" />
          
        </a>
        <p>March 15-21, 2017</p>
      </div>
    
    
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedPopularity -->












<div id="SearchRightCol" class="MainSidebar BlogPost  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:d8alybonnui" action="http://www.clevescene.com/cleveland/Search?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SearchRightCol">
      <input type="hidden" name="cx" value="017793458706336421686:d8alybonnui" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="http://www.clevescene.com/cleveland/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="http://www.clevescene.com/cleveland/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="http://www.clevescene.com/cleveland/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="http://www.clevescene.com/cleveland/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            window.location = newLocation + "?keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="MainSidebar BlogPost MediumRectangle Ad">
  <!-- /43707298/CLE_300x250 -->
          <div id="div-gpt-ad-cle_300x250-1" style="" data-slot="/43707298/CLE_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_300x250-1');
                });
            </script>
          </div>
</div>


  <div id="NewsletterSignup" class="MainSidebar BlogPost ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <h3>Never miss a beat</h3>
<a href="/cleveland/ClevesceneNewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color: rgb(217, 31, 52);font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
    </div>
  </div>
  
<div id="ORATVAANPartnerWidget" class="MainSidebar BlogPost MediumRectangle Ad">
  <iframe width="300" height="169" src="//www.ora.tv/embed/partner/clevescene/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>
</div>








































<div id="TabbedCalendar" class="MainSidebar BlogPost ">
  <h2>Calendar</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
    </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/the-1980s-an-age-of-excess/Event?oid=5013596&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The 1980s: An Age of Excess <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/threads-of-the-past-art-with-an-eye-for-history/Event?oid=5391862&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Threads of the Past: art with an eye for history <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/bob-hope-an-american-treasure/Event?oid=4969740&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Bob Hope: An American Treasure <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/esther-teichmann-heavy-the-sea/Event?oid=5005861&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Esther Teichmann: Heavy the Sea <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/all-stravinsky/Event?oid=5448453&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        All Stravinsky <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
      
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventSection=1471254&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventSection=1471254&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventSection=1471254&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
    </div>
    <ol class="moduleList">
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/all-stravinsky/Event?oid=5448453&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        All Stravinsky <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/uli-jon-roth/Event?oid=5580328&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Uli Jon Roth <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/whats-on-david-bowies-playlist/Event?oid=5579748&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        "What's on David Bowie's Playlist" <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/candlebox-acoustic/Event?oid=5567152&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Candlebox — Acoustic <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/john-prine-night-in-the-supper-club/Event?oid=5567159&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        John Prine Night (in the Supper Club) <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
  </div>  

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
      
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventCategory=1471275&amp;narrowByDate=Today&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventCategory=1471275&amp;narrowByDate=Tomorrow&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
      <a class="grayRedBox" href="http://www.clevescene.com/cleveland/EventSearch?eventCategory=1471275&amp;narrowByDate=This%20Weekend&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
    </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/rocky-horror-picture-show-extravaganza-cleveland/Event?oid=5357677&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        'Rocky Horror Picture Show' Extravaganza Cleveland <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/best-of-ottawa/Event?oid=5623299&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Best of Ottawa <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/happy-hour-classic/Event?oid=5745948&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Happy Hour Classic <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/the-punk-singer/Event?oid=5758947&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Punk Singer <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/unbought-and-unbossed-chisholm-72/Event?oid=5516281&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Unbought and Unbossed: chisholm 72 <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/tea-house-noodles/Location?oid=1430928&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Tea House Noodles <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/caff-roma/Location?oid=1433253&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Caffé Roma <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="http://www.clevescene.com/cleveland/soho-kitchen-and-bar/Location?oid=2791518&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Soho Kitchen and Bar <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="http://www.clevescene.com/cleveland/LocationSearch?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
      <input type="hidden" name="locationSection" value="1435342" />
      <input type="hidden" name="guide" value="1515209" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="1525698">African/Ethiopian/Eritrean</option>
        
          <option value="1525664">American</option>
        
          <option value="1525689">Asian</option>
        
          <option value="2733408">Asian/Indian/Middle Eastern</option>
        
          <option value="1525665">Bakery</option>
        
          <option value="1525694">Barbecue</option>
        
          <option value="1525708">Brazilian</option>
        
          <option value="1525669">Breakfast</option>
        
          <option value="1525695">Brunch</option>
        
          <option value="1525680">Buffet</option>
        
          <option value="2714939">Cafes, Coffee Shops & Bakeries</option>
        
          <option value="1525681">Cajun/Creole</option>
        
          <option value="1525711">California cuisine</option>
        
          <option value="1525699">Cambodian</option>
        
          <option value="1525703">Caribbean</option>
        
          <option value="1525684">Central American</option>
        
          <option value="1525693">Central European</option>
        
          <option value="1525663">Chinese</option>
        
          <option value="1525696">Coffeehouse/Cafe</option>
        
          <option value="1525671">Contemporary</option>
        
          <option value="1525668">Continental</option>
        
          <option value="1536821">Cuban</option>
        
          <option value="1525662">Deli</option>
        
          <option value="1525683">Dessert</option>
        
          <option value="2714935">Destinations</option>
        
          <option value="1525705">Diner</option>
        
          <option value="1525700">Eastern European</option>
        
          <option value="1525670">Eclectic</option>
        
          <option value="1525672">English/Irish</option>
        
          <option value="1525710">European/Mediterranean</option>
        
          <option value="1525673">French</option>
        
          <option value="1525678">Global</option>
        
          <option value="1525688">Greek</option>
        
          <option value="1525706">Hawaiian</option>
        
          <option value="1525691">Home Cooking</option>
        
          <option value="1525690">Indian/Pakistani</option>
        
          <option value="1525660">Italian</option>
        
          <option value="2714936">Italian/Pizza</option>
        
          <option value="1525661">Japanese/Sushi</option>
        
          <option value="1525675">Mexican</option>
        
          <option value="1525676">Middle Eastern</option>
        
          <option value="1536819">Moroccan</option>
        
          <option value="1525707">New American</option>
        
          <option value="1525679">Pizza</option>
        
          <option value="1525658">Pub Fare/Breweries</option>
        
          <option value="2733413">Pubs/Wine & Martini Bars</option>
        
          <option value="1536820">Puerto Rican</option>
        
          <option value="1525666">Quick Casual</option>
        
          <option value="1523711">Restaurant</option>
        
          <option value="1525667">Seafood</option>
        
          <option value="1525704">Soup Kitchen</option>
        
          <option value="1536822">South American</option>
        
          <option value="1525712">South Indian</option>
        
          <option value="2714941">South of the Border</option>
        
          <option value="1525701">Southern/Soul Food</option>
        
          <option value="1536816">Southwestern</option>
        
          <option value="1536815">Spanish</option>
        
          <option value="1525677">Steakhouse</option>
        
          <option value="2714940">Steaks & Seafood</option>
        
          <option value="1525659">Subs/Sandwich Shop</option>
        
          <option value="1525709">Sushi</option>
        
          <option value="1525702">Tea Room</option>
        
          <option value="1536818">Tex-Mex</option>
        
          <option value="1525674">Thai</option>
        
          <option value="1536817">Vegetarian</option>
        
          <option value="1525686">Vietnamese</option>
        
          <option value="1525692">Wine/Martini Bar</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="1430804" >DOWNTOWN</option>
        
        <option value="1430810" >&nbsp;&nbsp;Downtown/Flats/Warehouse District</option>
      
        
        <option value="1430819" >&nbsp;&nbsp;West Side/Ohio City/Tremont/Detroit Shoreway</option>
      
        
          <option value="1430801" >EAST</option>
        
        <option value="1430807" >&nbsp;&nbsp;East Side/University Circle/Little Italy</option>
      
        
        <option value="1430808" >&nbsp;&nbsp;Eastern OH</option>
      
        
        <option value="1430812" >&nbsp;&nbsp;Eastern Suburbs</option>
      
        
        <option value="1430815" >&nbsp;&nbsp;Mentor/Lake County</option>
      
        
        <option value="1430816" >&nbsp;&nbsp;Northern OH</option>
      
        
          <option value="1430802" >WEST</option>
        
        <option value="1430820" >&nbsp;&nbsp;Western OH</option>
      
        
        <option value="1430821" >&nbsp;&nbsp;Western Suburbs</option>
      
        
          <option value="1430803" >SOUTH</option>
        
        <option value="1430806" >&nbsp;&nbsp;Akron/Summit County</option>
      
        
        <option value="1430809" >&nbsp;&nbsp;Canton/Stark County</option>
      
        
        <option value="1430813" >&nbsp;&nbsp;Kent/Portage County</option>
      
        
        <option value="1430814" >&nbsp;&nbsp;Medina County</option>
      
        
        <option value="1430817" >&nbsp;&nbsp;Southern OH</option>
      
        
        <option value="1430818" >&nbsp;&nbsp;Southern Suburbs</option>
      
        
          <option value="1430805" >CENTRAL OH</option>
        
        <option value="1430811" >&nbsp;&nbsp;Central OH</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedCalendar -->

  <div id="PromoGraphicLinkcustom" class="MainSidebar BlogPost ">
    <ul class="componentBody">
      
        <li class="left">
          
            <a href="clevescenetickets.com"><img src="/binary/014f/unnamed.jpg" /></a>
          
        </li>    
      
    </ul>
    
  </div>
<div id="AdMediumRectangle2300x250" class="MainSidebar BlogPost ">
  <!-- /43707298/CLE_300x250 -->
          <div id="div-gpt-ad-cle_300x250-2" style="" data-slot="/43707298/CLE_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_300x250-2');
                });
            </script>
          </div>
</div>

<div id="PhotoSlideshows" class="MainSidebar BlogPost ">
  <h2><a href="http://photos.clevescene.com/" target="_blank">Newest Slideshows</a></h2>
  <iframe src="//photos.clevescene.com/thumbnail-scroller-post/" 
          height="419" 
          width="364"
          scrolling="no" 
          frameborder="0"></iframe>
</div>
<!-- End #PhotoSlideshows -->














    <div id="SpecialIssues" class="MainSidebar BlogPost ">
      <h2><a href="http://www.clevescene.com/cleveland/special-sections/Section?oid=1518239&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/cleveland/flavor/Category?oid=3801465&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/clevescene/imager/u/original/4680557/2d1fafe6-dc37-49df-9404-ad26cda099d6.jpg);">
      <span class="grayRedBox">Flavor</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/cleveland/cleveland-people/Category?oid=3631702&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/clevescene/imager/u/original/4955778/bestof.jpg);">
      <span class="grayRedBox">The People Issue</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/cleveland/summer-guide-2015/Category?oid=4585626&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/clevescene/imager/u/original/4594719/unnamed.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/cleveland/Survey?survey=5022717&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/clevescene/imager/u/original/4594716/as.jpg);">
      <span class="grayRedBox">Best of Cleveland</span>
    </a>
  </div>
  

      <a href="http://www.clevescene.com/cleveland/special-sections/Section?oid=1518239&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="MainSidebar BlogPost ">
  <!-- /43707298/CLE_300x250 -->
          <div id="div-gpt-ad-cle_300x250-3" style="" data-slot="/43707298/CLE_300x250" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_300x250-3');
                });
            </script>
          </div>
</div>
        <!-- end gridMainSidebar -->
      </div>

      <!-- ZoneC -->
      <div id="gridMainSidebarJr">
        
        <!-- end gridAdSidebar -->
      </div>

      <!-- ZoneD -->
      <div id="gridMainSidebarJr2">
        
        <!-- end gridAdSidebar2 -->
      </div>
      
      <!-- Zone E -->
      <div id="gridBottomSidebar">
        
        <!-- end gridBottomSidebar -->
      </div>
      
      <!-- end gridRightColumn -->
    </div>

    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter BlogPost ">
  <div class="footerCustomInfo">
    <h2>Cleveland Scene</h2>
    <p>737 Bolivar Rd., Suite 4100</p>
    <p>Cleveland, OH, 44115</p>
    <p>Main: (216) 241-7550</p>
    <p>Advertising: (216) 802-7241</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="http://www.clevescene.com/cleveland/Contact/Page">Contact CleveScene</a></li>
        <li><a target="_top" href="http://www.clevescene.com/cleveland/AdvertisingInfo/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
        <li><a target="_top" href="http://www.clevescene.com/cleveland/Jobs/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2017 Cleveland Scene.</p>
    </div>
    <div class="footerRssLink">
      <a href="http://www.clevescene.com/cleveland/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    

    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="http://posting.clevescene.com/cleveland/MyProfile">View Profile</a> / </li>
          <li><a href="http://posting.clevescene.com/cleveland/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="http://www.clevescene.com/cleveland/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdLeaderboard2RunofSite" class="GlobalFooter BlogPost Leaderboard Ad">
  <!-- /43707298/CLE_728x90 -->
          <div id="div-gpt-ad-cle_728x90-2" style="" data-slot="/43707298/CLE_728x90" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_728x90-2');
                });
            </script>
          </div>
</div>


















<div id="FooterNavigationCustom" class="GlobalFooter BlogPost ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/news/Section?oid=1392923" 
               target="_">
              News
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/news/Section?oid=1392923" >News Home</a></li>
          
            <li><a href="/cleveland/news-features/Category?oid=1518227" >Features</a></li>
          
            <li><a href="/cleveland/cover-story/Content?special=1521546" >Cover Story</a></li>
          
            <li><a href="/blogs/scene-and-heard/" >Scene & Heard: Scene's News Blog</a></li>
          
            <li><a href="/cleveland/IssueArchives?issue=this%20week" target="_blank">e-Edition</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/music/Section?oid=1392924" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/music/Section?oid=1392924" >Music Home</a></li>
          
            <li><a href="/cleveland/music-feature/Category?oid=1518237" >Features</a></li>
          
            <li><a href="/cleveland/music-lead/Content?category=1518228" >Music Lead</a></li>
          
            <li><a href="/cleveland/discourse-reviews/Category?oid=1518232" >CD Reviews</a></li>
          
            <li><a href="/cleveland/band-of-the-week/Content?category=1518236" >Band of the Week</a></li>
          
            <li><a href="http://clevescene.getn2.it/" target="_blank">Concert Listings</a></li>
          
            <li><a href="/cleveland/EventSearch?feature=Club&eventSection=1471254" >Club Listings</a></li>
          
            <li><a href="/cleveland/museums/LocationSearch?locationCategory=1430792" >Music Venues</a></li>
          
            <li><a href="http://clevescene.getn2.it/form/userSubmit?type=event" target="_blank">Submit a Concert Listing</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/film/Section?oid=1392922" 
               target="_">
              Movies
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/film/Section?oid=1392922" >Film Home Page</a></li>
          
            <li><a href="/cleveland/film-lead/Content?category=1518224" >Film Lead</a></li>
          
            <li><a href="/cleveland/film-features/Content?category=1518238" >Features</a></li>
          
            <li><a href="/cleveland/LocationSearch?locationCategory=1430798" >Movie Theaters</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/dining/Section?oid=1392921" 
               target="_">
              Eat
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/drink-up/Category?oid=2703757" >Drink Up</a></li>
          
            <li><a href="/cleveland/dining/Section?oid=1392921" >Dining Home Page</a></li>
          
            <li><a href="/cleveland/dining-lead/Content?category=1518226" >Dining Review</a></li>
          
            <li><a href="/cleveland/food-features/Category?oid=1520384" >Food Features</a></li>
          
            <li><a href="/cleveland/patio-guide-spice-kitchen-bar/Content?oid=4341400" >Patio Spotlight</a></li>
          
            <li><a href="/cleveland/drink-features/Content?category=3206404" >Drink Features</a></li>
          
            <li><a href="http://happyhours.clevescene.com/cleveland/find/places" >Happy Hour Guide</a></li>
          
            <li><a href="/cleveland/LocationSearch?locationSection=1435342" >Dining Guide</a></li>
          
            <li><a href="/cleveland/LocationSearch?feature=Menu" >Restaurant Menus</a></li>
          
            <li><a href="/cleveland/LocationSearch?locationCategory=1430791" >Wineries/Breweries</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/arts/Section?oid=1392919" 
               target="_">
              Arts
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/arts/Section?oid=1392919" >Arts Home Page</a></li>
          
            <li><a href="/cleveland/theater/Category?oid=1518230" >Theater Reviews</a></li>
          
            <li><a href="/cleveland/visual-art/Category?oid=1518229" >Art Reviews</a></li>
          
            <li><a href="/cleveland/galleries/LocationSearch?locationCategory=1528779" >Galleries</a></li>
          
            <li><a href="/cleveland/museums/LocationSearch?locationCategory=1528780" >Museums</a></li>
          
            <li><a href="/cleveland/theaters/LocationSearch?locationCategory=1528781" >Theraters</a></li>
          
            <li><a href="/cleveland/LocationSearch?locationCategory=1430795" >Other Arts Venues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/EventSearch?narrowByDate=Today&eventSection=1173452" 
               target="_">
              Get Out
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/general/pdfs/trailsofterror.PDF" target="_blank">Trails of Terror</a></li>
          
            <li><a href="/cleveland/EventSearch" >Events Home Page</a></li>
          
            <li><a href="/cleveland/EventSearch?narrowByDate=Today&eventSection=1173452" >Event Calendar</a></li>
          
            <li><a href="http://clevescene.getn2.it/" target="_blank">Concert Listings</a></li>
          
            <li><a href="/cleveland/Events/AddEvent" >Submit an Event</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/cleveland/special-sections/Section?oid=1518239" 
               target="_">
              Special Sections
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="http://www.clevescene.com/cleveland/flavor/Category?oid=3801465">Flavor</a></li>
  
    <li><a href="http://www.clevescene.com/cleveland/cleveland-people/Category?oid=3631702">Cleveland People</a></li>
  
    <li><a href="http://www.clevescene.com/cleveland/cleveland-2021/Category?oid=4714410">Cleveland 2021</a></li>

          
            <li><a href="/cleveland/welcome-to-city-guide/Category?oid=4491140" >City Guide</a></li>
          
            <li><a href="/cleveland/Survey?survey=5022717" >Best of Cleveland</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="http://cleveland.backpage.com/online/classifieds/index" 
               target="_">
              Classifieds
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://cleveland.backpage.com/online/classifieds/index" target="_blank">Classifieds Search</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="http://cleveland.backpage.com/personals/classifieds/Disclaimer?section=4383" 
               target="_blank">
              Personals
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://cleveland.backpage.com/personals/classifieds/Disclaimer?section=4383" target="_blank">Personals Search</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://www.facebook.com/ClevelandScene" target="_blank">Facebook</a></li>
          
            <li><a href="https://twitter.com/ClevelandScene" target="_blank">Twitter</a></li>
          
            <li><a href="http://statigr.am/ClevelandScene" target="_blank">Instagram</a></li>
          
            <li><a href="https://plus.google.com/108630931754112472513" target="_blank">Google Plus</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>About CleveScene</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/cleveland/PrivacyPolicy/Page" >Privacy Policy</a></li>
          
            <li><a href="/general/pdfs/2015-PrintMediaKit.pdf" target="_blank">Media Kit</a></li>
          
            <li><a href="/cleveland/AdvertisingInfo/Page" >Advertising Info</a></li>
          
            <li><a href="/cleveland/Contact/Page" >Contact</a></li>
          
            <li><a href="/cleveland/Jobs/Page" >Jobs</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigationCustom -->
<div id="footerCopyright">
  <p>
    &copy; 2017 Cleveland Scene: 
    737 Bolivar Rd.,
    Suite 4100,
    Cleveland,
    OH
    44115,
    (216) 241-7550<br />
    Logos and trademarks on this site are property of their respective owners.
  </p>
  <br>
  <p>Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a></p>

</div>


  <img src="/foundation/images/icons/pixel.gif?oid=5798143" alt="" />


      <!-- end gridFooter -->
    </div>
    
    <!-- end gridMain -->
  </div>
  
  <!-- end gridClamp -->
</div>

<!-- Closer -->
<div id="gridCloser">
  <style>
div#AdReskin {position:fixed;z-index:-1;top:0;left:50%;margin:0 auto;}
div#AdReskin .adWrapper {display:block;z-index:0;margin:0 0 0 -50%;}
body {position:relative; z-index:0;}
</style>
<div id="AdReskin" class="Closer BlogPost Ad">
  <div class="adWrapper">
    <!-- /43707298/CLE_Reskin -->
          <div id="div-gpt-ad-cle_reskin" style="" data-slot="/43707298/CLE_Reskin" data-output="asynchronous" data-width="" data-height="">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-cle_reskin');
                });
            </script>
          </div>
  </div>
</div>
</div><!-- end gridCloser -->


    </body>
</html>
  


